camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hadrian Zbarcea <hzbar...@gmail.com>
Subject Re: echo() processor
Date Fri, 22 Aug 2008 17:15:51 GMT
@Claus,

True.  I guess using a bean in that case should be acceptable.  It's  
not 1-to-1 translation of the dsl, but should it be?

Hadrian


On Aug 22, 2008, at 6:19 AM, Fintan Bolton wrote:

>
> Hi Claus,
>
> If using a static method inside process(...), it might be clearer to  
> give it
> a more explicit name. For example:
>
> from(...).process(copyInToOut());
>
> -
> Fintan
>
>
> -----Original Message-----
> Hi
>
> The static solution is neat however it is not avail for the Spring XML
> routing.
>
> But I like the idea, but is the echo name a common pattern / term  
> for such a
> copy-in-to-out? I think Mule has a similar component also. So it  
> might not
> be to bad to introduce.
>
> Maybe it will be obsolete if the camel components is smarter / more  
> strict
> about the MEP patterns the support/use.
>
>
>
> Med venlig hilsen
>
> Claus Ibsen
> ......................................
> Silverbullet
> Skovsgårdsvænget 21
> 8362 Hørning
> Tlf. +45 2962 7576
> Web: www.silverbullet.dk
>
> -----Original Message-----
> From: Hadrian Zbarcea [mailto:hzbarcea@gmail.com]
> Sent: 21. august 2008 18:32
> To: camel-user@activemq.apache.org
> Subject: Re: echo() processor
>
> The DSL is big as it is.  We add to it integration patterns, but my
> personal preference would be to not add things like echo().  I would
> more in favor of having it a (static) method that returns a processor,
> so one would use it like:
>
> from(...).process(echo());
>
> My $0.02,
> Hadrian
>
> -- 
> View this message in context: http://www.nabble.com/echo%28%29-processor-tp19086322s22882p19104719.html
> Sent from the Camel - Users mailing list archive at Nabble.com.
>


Mime
View raw message