camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen" ...@silverbullet.dk>
Subject RE: Failed to resolve endpoint unknown parameters delay (for file component) !!
Date Thu, 10 Jul 2008 06:59:33 GMT
What did you do since it stopped working?
- Upgrade Camel from 1.3 to 1.4-SNAPSHOT?
- Changed something in your code?
- etc.

Could you provide more details. Please check the DEBUG log to see what Camel is doing. Maybe
there is an ERROR and its picked up the the dead letter channel. Etc.


Med venlig hilsen
 
Claus Ibsen
......................................
Silverbullet
Skovsgårdsvænget 21
8362 Hørning
Tlf. +45 2962 7576
Web: www.silverbullet.dk

-----Original Message-----
From: cmoulliard [mailto:cmoulliard@gmail.com] 
Sent: 10. juli 2008 08:49
To: camel-user@activemq.apache.org
Subject: RE: Failed to resolve endpoint unknown parameters delay (for file component) !!


Thxs.

I see also that the polling does not work anymore. When I launch Camel and
that I copy a file in the directory, the file will be processed but when I
copy a new file, nothing happens !!!


Claus Ibsen wrote:
> 
> Hi Charles
> 
> Sorry you should user this parameter name:
> consumer.delay=10000
> 
> So it should be:
> file:///c:/temp/test/?delete=true&consumer.delay=10000
> 
> It requires the consumer. prefix as it's a parameter to the underlying
> consumer class that has a few parameters that is required to be prefixed
> with consumer.
> 
> We should probably write this in the release note for Camel 1.4. Oh no a
> task for me to remember.
> 
> 
> Med venlig hilsen
>  
> Claus Ibsen
> ......................................
> Silverbullet
> Skovsgårdsvænget 21
> 8362 Hørning
> Tlf. +45 2962 7576
> Web: www.silverbullet.dk
> 
> -----Original Message-----
> From: cmoulliard [mailto:cmoulliard@gmail.com] 
> Sent: 9. juli 2008 18:08
> To: camel-user@activemq.apache.org
> Subject: Failed to resolve endpoint unknown parameters delay (for file
> component) !!
> 
> 
> Hi,
> 
> I would like to inform you that with the snapshot 1.4 of camel, the delay
> attribute for file component is no longer recognised ?
> 
> org.apache.cmale.ResolveEndpointFailedException: Failed to resolve
> endpoint:
> file:///c:/temp/test/?delete=true&delay=10000 due to: There are 1
> parameters
> that couldn't be set on the endpoint. Check the uri if the parameters are
> spelt correctly and that they are properties of the endpoint. Unknown
> parameters = [{delay=10000}]
> 
> Regards,
> 
> Charles
> -- 
> View this message in context:
> http://www.nabble.com/Failed-to-resolve-endpoint--unknown-parameters-delay-%28for-file-component%29-%21%21-tp18364457s22882p18364457.html
> Sent from the Camel - Users mailing list archive at Nabble.com.
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Failed-to-resolve-endpoint--unknown-parameters-delay-%28for-file-component%29-%21%21-tp18364457s22882p18376960.html
Sent from the Camel - Users mailing list archive at Nabble.com.


Mime
View raw message