camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem Jiang <willem.ji...@gmail.com>
Subject Re: Camel cxf route interception and SOAP messages
Date Tue, 01 Apr 2008 04:37:51 GMT
Hi ,

Do you use the SAAJ to build up the SOAP message ?
Maybe you need to show us the codes or a small test case to let us 
reproduce the error.

Willem

Ian de Beer wrote:
> Hi
> I have created a camel route similar to the cxf provider example. The
> exchange is correctly routed to a bean that creates a SOAP message . Before
> I return the message I display it and I can verify that it contains the
> correct response. However when the response message arrives back at the SOAP
> client the content of the SOAP message body has mysteriously disappeared. I
> also notice that the namespaces has changed from what I have set them to.
> What I send:
> <SOAP-ENV:Envelope
> xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
> xmlns:ns1="http://poc.tatis.com/"
> xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
> xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
> xmlns:xsd="http://www.w3.org/2001/XMLSchema"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Header/><SOAP-ENV:Body><ns1:getRatingResponse><rating
> xsi:type="xsd:float">123.11</rating></ns1:getRatingResponse></SOAP-ENV:Body></SOAP-ENV:Envelope>
>
> What I receive:
> <soap:Envelope
> xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Body><ns1:getRatingResponse
> xmlns:ns1="http://poc.tatis.com/"/></soap:Body></soap:Envelope> 
>
> Can someone perhaps shed some light on this behaviour.
> Regards
> Ian
>   


Mime
View raw message