camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <>
Subject Re: Getting lots of TIME_WAIT sockets
Date Thu, 20 Mar 2008 13:21:20 GMT
On 20/03/2008, James Strachan <> wrote:
> On 20/03/2008, DominicTulley <> wrote:
>  >
> >  Sorry for the noise - I just end up following my nose trying to find a way
>  >  round the problem.
> No problem :)
>  >  The easiest way to reproduce the problem is simply to pump a bunch of
>  >  messages through a standard camel route defined in activemq.xml.  I see the
>  >  problem with the standard distro of amq and camel (As built from svn) by
>  >  just adding a single route (with activemq: as the component) and exercising
>  >  it.
> Great - let me take a look...

So I've tried reproducing this and can't.

Here's what I did

* grabbed latest trunk of camel & built it
* grabbed latest trunk of activemq and built it

* ran the out of the box activemq tarball

cd activemq/assembly
tar xf apache-activemq*.tar.gz
cd apache-activemq*

then ran the camel soak test in a separate JVM...

cd activemq/activemq-camel-loadtest
mvn test -Dtest=LocalBrokerLoadTest

This camel based load test will fire a bunch of messages into a queue
(example.A the same one used by default the camel route inside the
broker). Then it'll consume from (example.B) the one used by the camel
route in the broker - and assert it receives all the right messages in
order etc.

When I run this I see only 1 socket open connecting to port 61616
inside the JVM of the broker. I see only 1 socket connecting from the
other process.

e.g. running

 lsof -i | grep ":61616"


java      13735 jstrachan   31u  IPv6 0x14670b2c      0t0  TCP
[::]:61616->[::]:50651 (ESTABLISHED)
java      13735 jstrachan   33u  IPv6 0x1467fe4c      0t0  TCP
[::]:50652->[::]:61616 (ESTABLISHED)
java      13735 jstrachan   34u  IPv6 0x14682cd4      0t0  TCP
[::]:61616->[::]:50652 (ESTABLISHED)
java      13735 jstrachan   48u  IPv6  0x6e97b2c      0t0  TCP *:61616 (LISTEN)
java      13735 jstrachan   65u  IPv6  0x6e960e0      0t0  TCP
[::]:58826->[::]:61616 (ESTABLISHED)
java      13735 jstrachan   66u  IPv6  0xd0a5be8      0t0  TCP
[::]:61616->[::]:58826 (ESTABLISHED)
java      14100 jstrachan    7u  IPv6 0x146a319c      0t0  TCP
[::]:50564->[::]:61616 (ESTABLISHED)

There's a bunch of other sockets on different ports in the broker; as
the broker by default starts Jetty with the web console & web demo
along with other transports (SSL / stomp) and JMX etc.

I wonder if you try the above steps, do you get the same results?


Open Source Integration

View raw message