camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From DominicTulley <>
Subject Re: Getting lots of TIME_WAIT sockets
Date Thu, 27 Mar 2008 12:02:37 GMT

Hi James, I've just realised..

lsof -i doesn't show TIME_WAIT sockets!

> Great - let me take a look...

So I've tried reproducing this and can't.

Here's what I did

When I run this I see only 1 socket open connecting to port 61616
inside the JVM of the broker. I see only 1 socket connecting from the
other process.

e.g. running

 lsof -i | grep ":61616"


java      13735 jstrachan   31u  IPv6 0x14670b2c      0t0  TCP
[::]:61616->[::]:50651 (ESTABLISHED)
java      13735 jstrachan   33u  IPv6 0x1467fe4c      0t0  TCP
[::]:50652->[::]:61616 (ESTABLISHED)
java      13735 jstrachan   34u  IPv6 0x14682cd4      0t0  TCP
[::]:61616->[::]:50652 (ESTABLISHED)
java      13735 jstrachan   48u  IPv6  0x6e97b2c      0t0  TCP *:61616
java      13735 jstrachan   65u  IPv6  0x6e960e0      0t0  TCP
[::]:58826->[::]:61616 (ESTABLISHED)
java      13735 jstrachan   66u  IPv6  0xd0a5be8      0t0  TCP
[::]:61616->[::]:58826 (ESTABLISHED)
java      14100 jstrachan    7u  IPv6 0x146a319c      0t0  TCP
[::]:50564->[::]:61616 (ESTABLISHED)

There's a bunch of other sockets on different ports in the broker; as
the broker by default starts Jetty with the web console & web demo
along with other transports (SSL / stomp) and JMX etc.

I wonder if you try the above steps, do you get the same results?


Open Source Integration

View this message in context:
Sent from the Camel - Users mailing list archive at

View raw message