camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <>
Subject Re: Problem using the mina component
Date Wed, 28 Nov 2007 09:16:15 GMT
On 28/11/2007, James Chamberlain <> wrote:
> I just started doing some testing on the mina work with some real data
> and I ran into a few issues.
> I was continuing to have problems with the MINA codec so dug in to see
> what was happening.
> First thing I saw looks like just a simple typo. In the
> configureDataGramCodecFactory method on the MinaComponent, the last
> line adds a new TextLineCodecFactory instead of the codecFactory
> created above. This was easily fixed by changing the last line.

Great catch - doh! :)

I've patched the code to fix that.

> Then I ran into issues with it being able to convert from byte[] to
> ByteBuffer, none of the built in converters know how to perform that
> conversion.

Hmm - this is a MINA ByteBuffer right? Does the
MinaConverter.toByteArray() not get invoked? (The src/main/resources
must be on the classpath to auto-discover the MINA type conversions)

> That's probably pretty straight forward to create a
> converter to handle it. To continue my testing I just performed the
> conversion in the MinaComponent, but that's not the right way to do it
> long term.
> I needed to have multicast support so I ended up writing a new
> component that mirrors what the mina component does, but does not use
> nio. I'm not done with it yet, but if your interested I could
> contribute it when it is complete.

That'd be awesome, we love contributions! :)


Open Source Integration

View raw message