camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tadayoshi Sato (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (CAMEL-11768) camel-itest-karaf - CamelDockerTest fails
Date Mon, 11 Sep 2017 03:09:00 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-11768?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tadayoshi Sato reassigned CAMEL-11768:
--------------------------------------

    Assignee: Tadayoshi Sato

> camel-itest-karaf - CamelDockerTest fails
> -----------------------------------------
>
>                 Key: CAMEL-11768
>                 URL: https://issues.apache.org/jira/browse/CAMEL-11768
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-docker, tests
>    Affects Versions: 2.20.0
>            Reporter: Tadayoshi Sato
>            Assignee: Tadayoshi Sato
>
> {code}
> $ ./run-tests.sh CamelDockerTest
> ...
> Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 10.596 sec <<<
FAILURE! - in org.apache.camel.itest.karaf.CamelDockerTest
> test(org.apache.camel.itest.karaf.CamelDockerTest)  Time elapsed: 10.445 sec  <<<
ERROR!
> org.ops4j.pax.exam.WrappedTestContainerException: [test(org.apache.camel.itest.karaf.CamelDockerTest):
Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=camel-docker;
type=karaf.feature; version="[2.20.0.SNAPSHOT,2.20.0.SNAPSHOT]"; filter:="(&(osgi.identity=camel-docker)(type=karaf.feature)(version>=2.20.0.SNAPSHOT)(version<=2.20.0.SNAPSHOT))"
[caused by: Unable to resolve camel-docker/2.20.0.SNAPSHOT: missing requirement [camel-docker/2.20.0.SNAPSHOT]
osgi.identity; osgi.identity=org.apache.camel.camel-docker; type=osgi.bundle; version="[2.20.0.SNAPSHOT,2.20.0.SNAPSHOT]";
resolution:=mandatory [caused by: Unable to resolve org.apache.camel.camel-docker/2.20.0.SNAPSHOT:
missing requirement [org.apache.camel.camel-docker/2.20.0.SNAPSHOT] osgi.wiring.package; filter:="(&(osgi.wiring.package=com.github.dockerjava.api.async)(version>=3.0.0)(!(version>=4.0.0)))"
[caused by: Unable to resolve org.apache.servicemix.bundles.docker-java/3.0.13.1: missing
requirement [org.apache.servicemix.bundles.docker-java/3.0.13.1] osgi.wiring.package; filter:="(&(osgi.wiring.package=javax.annotation)(version>=1.2.0)(!(version>=2.0.0)))"]]]]
> 	at org.apache.felix.resolver.ResolutionError.toException(ResolutionError.java:42)
> 	at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:389)
> 	at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:375)
> 	at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:347)
> 	at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:218)
> 	at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:291)
> 	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1233)
> 	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$0(FeaturesServiceImpl.java:1132)
> 	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
> 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
> 	at java.lang.Thread.run(Thread.java:748)
> Results :
> Tests in error: 
>   CamelDockerTest.test ยป WrappedTestContainer [test(org.apache.camel.itest.karaf...
> Tests run: 1, Failures: 0, Errors: 1, Skipped: 0
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 15.983 s
> [INFO] Finished at: 2017-09-11T11:15:12+09:00
> [INFO] Final Memory: 41M/2875M
> [INFO] ------------------------------------------------------------------------
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message