camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zoran Regvart (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-11476) spring-boot - routes not loaded when setting a management.port
Date Wed, 28 Jun 2017 18:22:00 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-11476?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16066995#comment-16066995
] 

Zoran Regvart commented on CAMEL-11476:
---------------------------------------

[~davsclaus] yes, and I think [~nferraro] alluded to that in the description, but I verified,
with 2.19.1 {{camel-example-spring-boot}} and {{management.port=8081}} finds the {{RouteBuilder}}
route, with 2.20.0-SNAPSHOT it does not.

> spring-boot - routes not loaded when setting a management.port
> --------------------------------------------------------------
>
>                 Key: CAMEL-11476
>                 URL: https://issues.apache.org/jira/browse/CAMEL-11476
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-spring-boot
>    Affects Versions: 2.20.0
>            Reporter: Nicola Ferraro
>            Assignee: Zoran Regvart
>             Fix For: 2.20.0
>
>
> This is a really weird bug. If you set:
> {code}
> management.port=8081
> {code}
> On the application.properties file of any spring-boot application using actuator, then
camel routes created through RouteBuilders are not loaded ("Total 0 routes, of which 0 are
started."). 
> I've found it in (all) the fabric8 basic quickstarts, but it happens also in the "camel-example-spring-boot"
bundled with Apache Camel. Everything works in 2.19.x.
> Setting a different management port is a best practice. 
> [~zregvart], [~cibsen@e-ma.net], [~lb] any idea?



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message