camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexey Markevich (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CAMEL-11472) [camel-box] missing Karaf feature dependency
Date Wed, 28 Jun 2017 09:59:00 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-11472?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alexey Markevich updated CAMEL-11472:
-------------------------------------
    Attachment: camel-box.patch

> [camel-box] missing Karaf feature dependency
> --------------------------------------------
>
>                 Key: CAMEL-11472
>                 URL: https://issues.apache.org/jira/browse/CAMEL-11472
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-box
>    Affects Versions: 2.17.6
>            Reporter: Alexey Markevich
>         Attachments: camel-box.patch
>
>
> {noformat}
> karaf@root()> repo-add mvn:org.apache.camel.karaf/apache-camel/2.17.6/xml/features
> Adding feature url mvn:org.apache.camel.karaf/apache-camel/2.17.6/xml/features
> karaf@root()> feature:install camel-box
> Error executing command: Unable to resolve root: missing requirement [root] osgi.identity;
osgi.identity=camel-box; type
> =karaf.feature; version="[2.17.6,2.17.6]"; filter:="(&(osgi.identity=camel-box)(type=karaf.feature)(version>=2.17.6)(ver
> sion<=2.17.6))" [caused by: Unable to resolve camel-box/2.17.6: missing requirement
[camel-box/2.17.6] osgi.identity; os
> gi.identity=org.apache.camel.camel-box; type=osgi.bundle; version="[2.17.6,2.17.6]";
resolution:=mandatory [caused by: U
> nable to resolve org.apache.camel.camel-box/2.17.6: missing requirement [org.apache.camel.camel-box/2.17.6]
osgi.wiring.
> package; filter:="(osgi.wiring.package=com.gargoylesoftware.htmlunit)" [caused by: Unable
to resolve org.apache.servicem
> ix.bundles.htmlunit/2.20.0.1: missing requirement [org.apache.servicemix.bundles.htmlunit/2.20.0.1]
osgi.wiring.package;
>  filter:="(&(osgi.wiring.package=org.eclipse.jetty.websocket.client)(version>=9.2.0)(!(version>=10.0.0)))"
[caused by: U
> nable to resolve org.eclipse.jetty.websocket.client/9.3.14.v20161028: missing requirement
[org.eclipse.jetty.websocket.c
> lient/9.3.14.v20161028] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.eclipse.jetty.websocket.common.scopes)(
> version>=9.3.14)(!(version>=9.3.15)))" [caused by: Unable to resolve org.eclipse.jetty.websocket.common/9.3.14.v20161028
> : missing requirement [org.eclipse.jetty.websocket.common/9.3.14.v20161028] osgi.wiring.package;
filter:="(&(osgi.wiring
> .package=org.eclipse.jetty.websocket.api.util)(version>=9.3.14)(!(version>=9.3.15)))"
[caused by: Unable to resolve org.
> eclipse.jetty.websocket.api/9.3.14.v20161028: missing requirement [org.eclipse.jetty.websocket.api/9.3.14.v20161028]
osg
> i.identity; osgi.identity=pax-jetty-condition-pax_http_whiteboard; type=karaf.feature;
version="[9.3.14.v20161028,9.3.14
> .v20161028]"; resolution:=mandatory [caused by: Unable to resolve pax-jetty-condition-pax_http_whiteboard/9.3.14.v201610
> 28: missing requirement [pax-jetty-condition-pax_http_whiteboard/9.3.14.v20161028] osgi.identity;
osgi.identity=pax-http
> -whiteboard; type=karaf.feature; condition:=true]]]]]]]
> {noformat}
> workaround:
> {noformat}
> karaf@root()> feature:install pax-http-whiteboard
> karaf@root()> feature:install camel-box
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message