camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-11404) Upgrade to JPA 2.1
Date Tue, 20 Jun 2017 14:36:00 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-11404?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16055857#comment-16055857
] 

ASF GitHub Bot commented on CAMEL-11404:
----------------------------------------

GitHub user jamesnetherton opened a pull request:

    https://github.com/apache/camel/pull/1776

    CAMEL-11404: Upgrade Hibernate and JPA spec

    https://issues.apache.org/jira/browse/CAMEL-11404
    
    * Upgrades Hibernate & JPA spec dependencies
    * Adds Hibernate test profile to camel-jpa
    * Fixes minor test issues in camel-jpa

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/jamesnetherton/camel CAMEL-11404

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/camel/pull/1776.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #1776
    
----
commit badf43980deaaff4b75bcdbcbfd824c9f2d73b57
Author: James Netherton <jamesnetherton@gmail.com>
Date:   2017-06-20T12:57:55Z

    CAMEL-11404: Upgrade Hibernate and JPA spec

commit d7a5b0cc26166cd9bce3bff368e2737218c10657
Author: James Netherton <jamesnetherton@gmail.com>
Date:   2017-06-20T13:05:20Z

    CAMEL-11404: Add Hibernate test profile to camel-jpa

----


> Upgrade to JPA 2.1
> ------------------
>
>                 Key: CAMEL-11404
>                 URL: https://issues.apache.org/jira/browse/CAMEL-11404
>             Project: Camel
>          Issue Type: Improvement
>            Reporter: James Netherton
>            Assignee: James Netherton
>            Priority: Minor
>             Fix For: 2.20.0
>
>
> We have this in the Camel parent POM:
> {code:xml}
> <!-- Spring 3.2.x and 4.0.x still stick to JPA 2.0. Hibernate 4.3.x upgraded to JPA
2.1. -->
> <hibernate-version>4.2.20.Final</hibernate-version>
> {code}
> The JPA 2.1 spec has been around for quite some time now so maybe it's time to upgrade.

> AFAIK nothing is using Spring 3.2.x (except maybe the deprecated spring-dm?) or Spring
4.0.x. So we could bump the Hibernate version to something more recent (maybe 5.x aligned
with Spring Boot) together with the JPA spec.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message