camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Netherton (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (CAMEL-11404) Upgrade to JPA 2.1
Date Tue, 20 Jun 2017 06:26:00 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-11404?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

James Netherton reassigned CAMEL-11404:
---------------------------------------

    Assignee: James Netherton

> Upgrade to JPA 2.1
> ------------------
>
>                 Key: CAMEL-11404
>                 URL: https://issues.apache.org/jira/browse/CAMEL-11404
>             Project: Camel
>          Issue Type: Improvement
>            Reporter: James Netherton
>            Assignee: James Netherton
>            Priority: Minor
>             Fix For: 2.20.0
>
>
> We have this in the Camel parent POM:
> {code:xml}
> <!-- Spring 3.2.x and 4.0.x still stick to JPA 2.0. Hibernate 4.3.x upgraded to JPA
2.1. -->
> <hibernate-version>4.2.20.Final</hibernate-version>
> {code}
> The JPA 2.1 spec has been around for quite some time now so maybe it's time to upgrade.

> AFAIK nothing is using Spring 3.2.x (except maybe the deprecated spring-dm?) or Spring
4.0.x. So we could bump the Hibernate version to something more recent (maybe 5.x aligned
with Spring Boot) together with the JPA spec.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message