camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bob Blackard (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CAMEL-11029) camel-cdi won't install
Date Thu, 16 Mar 2017 19:10:41 GMT
Bob Blackard created CAMEL-11029:
------------------------------------

             Summary: camel-cdi won't install
                 Key: CAMEL-11029
                 URL: https://issues.apache.org/jira/browse/CAMEL-11029
             Project: Camel
          Issue Type: Bug
          Components: camel-cdi
    Affects Versions: 2.18.3, 2.18.2, 2.16.5, 2.16.4
         Environment: Verified in ServiceMix 7.0.0 and Karaf 4.1.0 with Oracle Java 8
            Reporter: Bob Blackard


Attempting to install camel-cdi feature results in an error.  I first installed pax-cdi and
pax-cdi-weld features, which installed fine, but attempting to install camel-cdi results in
a failure:

{code}
admin@root>feature:install camel-cdi
Error executing command: Unable to resolve root: missing requirement [root] osgi.identity;
osgi.identity=camel-cdi; type=karaf.feature; version="[2.16.4,2.16.4]"; filter:="(&(osgi.identity=camel-cdi)(type=karaf.feature)(version>=2.16.4)(version<=2.16.4))"
[caused by: Unable to resolve camel-cdi/2.16.4: missing requirement [camel-cdi/2.16.4] osgi.identity;
osgi.identity=org.apache.camel.camel-cdi; type=osgi.bundle; version="[2.16.4,2.16.4]"; resolution:=mandatory
[caused by: Unable to resolve org.apache.camel.camel-cdi/2.16.4: missing requirement [org.apache.camel.camel-cdi/2.16.4]
osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.deltaspike.core.util.metadata.builder)(version>=1.5.0)(!(version>=2.0.0)))"]]
{code}

The pax-cdi features are specifying version 1.3.0 (for RC1) or 1.4.2 (for RC2), but camel-cdi
is looking for version 1.5 and above.

I was able to get camel-cdi installed by first installing a newer version of deltaspike than
the one referenced by pax-cdi:

{code}
install mvn:org.apache.deltaspike.core/deltaspike-core-api/1.5.4
install mvn:org.apache.deltaspike.core/deltaspike-core-impl/1.5.4
feature:install camel-cdi
{code}

This also brings in pax-cdi 1.0.0.RC1.  However, my test bundle (based on camel-example-cdi-osgi
fails due to a problem with pax-cdi 1.0.0.RC1.

I am able to install and run my bundle just fine fine, when staring a scratch ServiceMix installation,
by overriding the pax-cdi and deltaspike using the script:

{code}
feature:repo-add mvn:org.ops4j.pax.cdi/pax-cdi-features/1.0.0.RC2/xml/features
install mvn:org.apache.deltaspike.core/deltaspike-core-api/1.7.2
install mvn:org.apache.deltaspike.core/deltaspike-core-impl/1.7.2
feature:install pax-cdi/1.0.0.RC2
feature:install pax-cdi-weld/1.0.0.RC2
feature:install camel-cdi
install -s mvn:com.omniprise.demo/camel-osgi-cdi/0.0.1-SNAPSHOT
{code}

I have also verified this on Camel 2.18.2 using Karaf 4.1.0 and the script:

{code}
feature:repo-add mvn:org.apache.camel.karaf/apache-camel/2.18.2/xml/features
feature:repo-add mvn:org.ops4j.pax.cdi/pax-cdi-features/1.0.0.RC2/xml/features
install mvn:org.apache.deltaspike.core/deltaspike-core-api/1.7.2
install mvn:org.apache.deltaspike.core/deltaspike-core-impl/1.7.2
feature:install pax-cdi/1.0.0.RC2
feature:install pax-cdi-weld/1.0.0.RC2
feature:install camel/2.18.2
feature:install camel-blueprint/2.18.2
feature:install camel-cdi/2.18.2
install -s mvn:com.omniprise.demo/camel-osgi-cdi/0.0.1-SNAPSHOT
{code}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message