camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrea Cosentino (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-10766) Create a new camel-elasticsearch5 component for supporting ElasticSearch 5.x Java API
Date Thu, 02 Feb 2017 09:18:51 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-10766?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15849701#comment-15849701
] 

Andrea Cosentino commented on CAMEL-10766:
------------------------------------------

In my opinion it is too soon for deprecation. I guess a lot of users still rely on ES 2.

> Create a new camel-elasticsearch5 component for supporting ElasticSearch 5.x Java API
> -------------------------------------------------------------------------------------
>
>                 Key: CAMEL-10766
>                 URL: https://issues.apache.org/jira/browse/CAMEL-10766
>             Project: Camel
>          Issue Type: New Feature
>          Components: camel-elasticsearch
>            Reporter: Dmitry Volodin
>             Fix For: 2.19.0
>
>
> We required Camel ElasticSearch component with latest ElasticSearch 5.x API support.
For backward compatibility we've migrated curent camel-elasticsearch to the new camel-elasticsearch5.
> As ${lucene-version} was defined globally, it affected on both ElasticSearch API versions
- 2.4.3 and 5.1.2 and one of the components doesn't work correctly. I was removed global Apache
Lucene library global definition and place it to the dependent components. Please correct
dependencies if needed. Also uploaded new component and all changes as patch.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message