camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-10716) Salesforce Composite API wrongly checks for minimum supported version
Date Tue, 17 Jan 2017 10:43:26 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-10716?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15825819#comment-15825819
] 

ASF GitHub Bot commented on CAMEL-10716:
----------------------------------------

GitHub user zregvart opened a pull request:

    https://github.com/apache/camel/pull/1402

    CAMEL-10716 Salesforce Composite API wrongly checks for minimum supported version

    Fixes an issue when the Batch request and the configured componentversion is version 34.0.
    
    Added unit test and refactored the check into separate method to make the unit test easier
to write.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/zregvart/camel CAMEL-10716

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/camel/pull/1402.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #1402
    
----
commit e0d2dfa55fb42f8da4d631328b1c3f196a8ed283
Author: Zoran Regvart <zoran@regvart.com>
Date:   2017-01-17T10:33:42Z

    CAMEL-10716 Salesforce Composite API wrongly ch...
    
    ...ecks for minimum supported version
    
    Fixes an issue when the Batch request and the configured component
    version is version 34.0.

----


> Salesforce Composite API wrongly checks for minimum supported version
> ---------------------------------------------------------------------
>
>                 Key: CAMEL-10716
>                 URL: https://issues.apache.org/jira/browse/CAMEL-10716
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-salesforce
>    Affects Versions: 2.19.0
>            Reporter: Zoran Regvart
>            Assignee: Zoran Regvart
>            Priority: Minor
>
> There is a check in the DefaultCompositeApiClient that checks if the configured version
is at least 34.0, this check wrongly reports an error if the version is configured exactly
at 34.0.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message