camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-10546) CamelContext - Rename getProperties to getConfiguration
Date Tue, 17 Jan 2017 09:30:26 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-10546?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15825706#comment-15825706
] 

Claus Ibsen commented on CAMEL-10546:
-------------------------------------

And we should also check camel-springboot as it may need to have this added as well about
globaloptions to its auto configuration and deprecate the old name

> CamelContext - Rename getProperties to getConfiguration
> -------------------------------------------------------
>
>                 Key: CAMEL-10546
>                 URL: https://issues.apache.org/jira/browse/CAMEL-10546
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-core
>            Reporter: Claus Ibsen
>            Priority: Minor
>             Fix For: 2.19.0
>
>
> People may mistake this with property placeholders. However its used for generic key/value
pairs for configuring some global options on CamelContext such as max debug log length etc.
> An alternative is to change this configuration to be a type safe configuration which
then adds fluent DSL support in Java and also in XML.
> But for 2.x we could add methods called getConfiguration() / setConfiguration() and deprecate
the older methods so people get more aware of this.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message