camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-10546) CamelContext - Rename getProperties to getConfiguration
Date Tue, 17 Jan 2017 09:16:26 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-10546?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15825692#comment-15825692
] 

Claus Ibsen commented on CAMEL-10546:
-------------------------------------

We would also need to have globalOptions in the XML DSL as today its called properties as
well. However we need the old to be deprecated so its backwards compatible. This is done in
camel-core-xml and camel-spring / camel-blueprint to adjust that kind of code.

eg this guys should be deprecated
org.apache.camel.model.PropertiesDefinition

And then we need a 
org.apache.camel.model.GlobalOptionsDefinition

And remember to add it to the jaxb.index file.

> CamelContext - Rename getProperties to getConfiguration
> -------------------------------------------------------
>
>                 Key: CAMEL-10546
>                 URL: https://issues.apache.org/jira/browse/CAMEL-10546
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-core
>            Reporter: Claus Ibsen
>            Priority: Minor
>             Fix For: 2.19.0
>
>
> People may mistake this with property placeholders. However its used for generic key/value
pairs for configuring some global options on CamelContext such as max debug log length etc.
> An alternative is to change this configuration to be a type safe configuration which
then adds fluent DSL support in Java and also in XML.
> But for 2.x we could add methods called getConfiguration() / setConfiguration() and deprecate
the older methods so people get more aware of this.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message