camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Dettinger (JIRA)" <>
Subject [jira] [Commented] (CAMEL-10546) CamelContext - Rename getProperties to getConfiguration
Date Thu, 12 Jan 2017 11:20:52 GMT


Alex Dettinger commented on CAMEL-10546:

My understanding is that the proposed refactoring is:
CamelContext.getProperties() => CamelContext.getConfiguration()
CamelContext.setProperties(Map<String, String> properties) => CamelContext.setConfiguration(Map<String,
String> configuration)

However, I'm wondering whether getProperty(String name) should be enrolled in the refactoring
too. I would then propose:
CamelContext.getProperties() => CamelContext.getGlobalOptions()
CamelContext.getProperty(String name) => CamelContext.getGlobalOption(String name)
CamelContext.setProperties(Map<String, String> properties) => CamelContext.setGlobalOptions(Map<String,
String> globalOptions)

What do you think ?

> CamelContext - Rename getProperties to getConfiguration
> -------------------------------------------------------
>                 Key: CAMEL-10546
>                 URL:
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-core
>            Reporter: Claus Ibsen
>            Priority: Minor
>             Fix For: 2.19.0
> People may mistake this with property placeholders. However its used for generic key/value
pairs for configuring some global options on CamelContext such as max debug log length etc.
> An alternative is to change this configuration to be a type safe configuration which
then adds fluent DSL support in Java and also in XML.
> But for 2.x we could add methods called getConfiguration() / setConfiguration() and deprecate
the older methods so people get more aware of this.

This message was sent by Atlassian JIRA

View raw message