camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Diesler (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CAMEL-10623) Camel CXF version not compatible with WildFly CXF
Date Tue, 20 Dec 2016 09:57:58 GMT
Thomas Diesler created CAMEL-10623:
--------------------------------------

             Summary: Camel CXF version not compatible with WildFly CXF
                 Key: CAMEL-10623
                 URL: https://issues.apache.org/jira/browse/CAMEL-10623
             Project: Camel
          Issue Type: Bug
          Components: camel-cxf
            Reporter: Thomas Diesler
             Fix For: 2.18.2, 2.19.0


cxf-3.1.9 distributed with camel-2.19.x is not compatible with cxf-3.1.6 from wildfly-10.1.0.Final

{code}
Caused by: java.lang.NoSuchMethodError: org.apache.cxf.message.Message.remove(Ljava/lang/Class;)Ljava/lang/Object;
	at org.apache.camel.component.cxf.CxfEndpoint$CamelCxfClientImpl.setParameters(CxfEndpoint.java:1239)
	at org.apache.cxf.endpoint.ClientImpl.doInvoke(ClientImpl.java:470)
	at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:416)
	at org.apache.camel.component.cxf.CxfProducer.process(CxfProducer.java:133)
{code}

CrossRef: https://github.com/wildfly-extras/wildfly-camel/issues/1546



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message