camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Terrien Jean-Yves (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-10554) camel-mongodb evolution to driver 3
Date Wed, 14 Dec 2016 12:43:58 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-10554?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15748256#comment-15748256
] 

Terrien Jean-Yves commented on CAMEL-10554:
-------------------------------------------

Sorry I've moved my code to camel-mongodb3.
Should the package be "org.apache.camel.component.mongodb" or "org.apache.camel.component.mongodb3"?
I am afraid that if I leave "org.apache.camel.component.mongodb", there will be conflicts,
if the two components are imported.

Bye

> camel-mongodb evolution to driver 3
> -----------------------------------
>
>                 Key: CAMEL-10554
>                 URL: https://issues.apache.org/jira/browse/CAMEL-10554
>             Project: Camel
>          Issue Type: Improvement
>    Affects Versions: 2.19.0
>            Reporter: Terrien Jean-Yves
>            Assignee: Andrea Cosentino
>            Priority: Minor
>         Attachments: mongo3.patch, mongo4.patch, mongo5.patch
>
>
> Hi, 
> The mongodb driver has changed in its foundation. 
> It is recommended not to use many classes of the verion 2 still present in the driver.

> This is the case with DBObject, which is the basis for the configuration of the camel
component. 
> I'm working on the evolution of this component to use the new classes of version 3, like
"Document". 
> I've created à patch (no completed)
> A+JYT



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message