camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zoran Regvart (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-10519) Disable TLSv1.0 in camel-salesforce
Date Thu, 24 Nov 2016 09:28:58 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-10519?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15692757#comment-15692757
] 

Zoran Regvart commented on CAMEL-10519:
---------------------------------------

[~davsclaus] thank you for that comment, I'm aware of that, could we do a point release of
2.17 so that any users still not on Java 8 can upgrade to that?

> Disable TLSv1.0 in camel-salesforce
> -----------------------------------
>
>                 Key: CAMEL-10519
>                 URL: https://issues.apache.org/jira/browse/CAMEL-10519
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-salesforce
>            Reporter: Zoran Regvart
>            Assignee: Zoran Regvart
>
> Salesforce is [disabling TLSv1.0|https://help.salesforce.com/HTViewSolution?id=000221207]
connections for production organizations on March 4, 2017.
> As a proactive measure for clients not running Java 8 (or newer) we should change the
defaults to disable TLSv.1.0 if the runtime supports TLSv1.1 or newer or issue a warning if
clients can use only TLSv1.0 (Java 6 before update 111).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message