camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Schneider (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CAMEL-10433) The camel-jetty, camel-jetty9 feature should explicitly define the expected feature version range for jetty
Date Wed, 02 Nov 2016 11:12:58 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-10433?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Christian Schneider resolved CAMEL-10433.
-----------------------------------------
       Resolution: Fixed
    Fix Version/s: 2.16.5
                   2.17.4

I did not mean to commit in spite of Andrea's comments. I only checked the issue before the
merge. At that point there were no comments. I always try to discuss before the commit if
there is a controversy.

In the meantime Andrea and I resolved the issue on IRC. We agreed on this:
The change is not be necessary if people follow the karaf guidelines but it should not do
any harm. So we can keep the commit.


> The camel-jetty, camel-jetty9 feature should explicitly define the expected feature version
range for jetty
> -----------------------------------------------------------------------------------------------------------
>
>                 Key: CAMEL-10433
>                 URL: https://issues.apache.org/jira/browse/CAMEL-10433
>             Project: Camel
>          Issue Type: Bug
>          Components: karaf
>    Affects Versions: 2.16.3, 2.17.3
>         Environment: Java 8
>            Reporter: Xilai Dai
>            Assignee: Christian Schneider
>            Priority: Minor
>             Fix For: 2.17.4, 2.16.5
>
>
> There is no version range restriction of jetty feature in the camel-jetty and camel-jetty9
feature definition.
> {code}
>     <feature>jetty</feature>
> {code}
> For camel-jetty9 feature, it maybe should add version range like this:
> {code}
>     <feature version='[9,10)'>jetty</feature>
> {code}
> For camel-jetty feature, it maybe should add version range like this:
> {code}
>     <feature version='[8,9)'>jetty</feature>
> {code}
> Because from karaf 4.x there are both jetty 8 and jetty 9 feature existing. Making this
changes will avoid install the wrong version jetty bundles when install camel-jetty (or camel-jetty8
of Camel 2.17.x)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message