camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CAMEL-10367) remove extraneous dependency from camel-amqp module
Date Fri, 07 Oct 2016 15:12:20 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-10367?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Claus Ibsen resolved CAMEL-10367.
---------------------------------
    Resolution: Fixed

> remove extraneous dependency from camel-amqp module
> ---------------------------------------------------
>
>                 Key: CAMEL-10367
>                 URL: https://issues.apache.org/jira/browse/CAMEL-10367
>             Project: Camel
>          Issue Type: Task
>          Components: camel-amqp
>    Affects Versions: 2.17.3
>            Reporter: Robbie Gemmell
>            Assignee: Claus Ibsen
>             Fix For: 2.19.0, 2.18.1
>
>
> I notice from http://camel.apache.org/amqp.html that camel-amqp is considered to support
only AMQP 1.0 as of Camel 2.17.0. The camel-amqp module however in addition to its dependency
on the newer Qpid AMQP 1.0 JMS client, continues to have a dependency on an old version of
the Qpid AMQP 0-x JMS client. Since it isn't used anymore this dependency should be removed.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message