camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-10124) Karaf commands - Switch to non deprecated
Date Tue, 11 Oct 2016 13:50:20 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-10124?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15565457#comment-15565457
] 

ASF GitHub Bot commented on CAMEL-10124:
----------------------------------------

GitHub user igarashitm opened a pull request:

    https://github.com/apache/camel/pull/1206

    CAMEL-10124 Karaf commands - Switch to non deprecated

    Note: This change is not compatible with karaf 2 and 3. If those old versions should be
still supported, then just keep using deprecated APIs which still seems to be working well
on karaf4 as well.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/igarashitm/camel CAMEL-10124

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/camel/pull/1206.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #1206
    
----
commit 2097a08225f327bd40ecba9da7ba325c880b6758
Author: Tomohisa Igarashi <tm.igarashi@gmail.com>
Date:   2016-10-07T03:43:11Z

    CAMEL-10124 Karaf commands - Switch to non deprecated

----


> Karaf commands - Switch to non deprecated
> -----------------------------------------
>
>                 Key: CAMEL-10124
>                 URL: https://issues.apache.org/jira/browse/CAMEL-10124
>             Project: Camel
>          Issue Type: Improvement
>          Components: karaf
>    Affects Versions: 2.18.0
>            Reporter: Claus Ibsen
>            Priority: Minor
>             Fix For: Future
>
>
> The karaf commands are using
>     <dependency>
>       <groupId>org.apache.karaf.shell</groupId>
>       <artifactId>org.apache.karaf.shell.console</artifactId>
>       <version>${karaf-version}</version>
>     </dependency>
> And that module is deprecated. There is some other module to be used.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message