camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-10249) The hawtdispatch-version should be 1.22 in the apache-camel-2.17.3-features.xml
Date Wed, 17 Aug 2016 07:56:23 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-10249?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15424054#comment-15424054
] 

Claus Ibsen commented on CAMEL-10249:
-------------------------------------

Can you provide a PR to fix this?
http://camel.apache.org/contributing

> The hawtdispatch-version should be 1.22 in the apache-camel-2.17.3-features.xml
> -------------------------------------------------------------------------------
>
>                 Key: CAMEL-10249
>                 URL: https://issues.apache.org/jira/browse/CAMEL-10249
>             Project: Camel
>          Issue Type: Bug
>          Components: karaf
>    Affects Versions: 2.17.3
>         Environment: Java 8
>            Reporter: Xilai Dai
>             Fix For: 2.17.4
>
>
> The error is thrown when try to install the camel-mqtt feature into karaf container.
> {code}
> karaf@root()> feature:install camel-mqtt
> Error executing command: Unable to resolve root: missing requirement [root] osgi.identity;
osgi.identity=camel-mqtt; typ
> e=karaf.feature; version="[2.17.3,2.17.3]"; filter:="(&(osgi.identity=camel-mqtt)(type=karaf.feature)(version>=2.17.3)(v
> ersion<=2.17.3))" [caused by: Unable to resolve camel-mqtt/2.17.3: missing requirement
[camel-mqtt/2.17.3] osgi.identity
> ; osgi.identity=org.apache.camel.camel-mqtt; type=osgi.bundle; version="[2.17.3,2.17.3]";
resolution:=mandatory [caused
> by: Unable to resolve org.apache.camel.camel-mqtt/2.17.3: missing requirement [org.apache.camel.camel-mqtt/2.17.3]
osgi.
> wiring.package; filter:="(&(osgi.wiring.package=org.fusesource.hawtdispatch)(version>=1.22.0)(!(version>=2.0.0)))"]]
> {code}
> The reason is mqtt-client expect org.fusesource.hawtdispatch.*;version=1.22, but it define
hawtdispatch 1.21 in the apache-camel-2.17.3-features.xml
> {code}
>     <bundle dependency='true'>mvn:org.fusesource.hawtdispatch/hawtdispatch/1.21</bundle>
>     <bundle dependency='true'>mvn:org.fusesource.hawtdispatch/hawtdispatch-transport/1.21</bundle>
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message