camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CAMEL-10089) Extend jline package import range in Camel commands
Date Wed, 10 Aug 2016 09:01:20 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-10089?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Claus Ibsen resolved CAMEL-10089.
---------------------------------
    Resolution: Fixed

I extended to include version 3.x as well.

> Extend jline package import range in Camel commands
> ---------------------------------------------------
>
>                 Key: CAMEL-10089
>                 URL: https://issues.apache.org/jira/browse/CAMEL-10089
>             Project: Camel
>          Issue Type: Task
>          Components: karaf
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 2.18.0
>
>
> Karaf master (4.1.x) has been upgraded to jline 3.
> The Camel Karaf commands should extend the import range to avoid:
> {code}
> gogo: ResolutionException: Unable to resolve root: missing requirement [root] osgi.identity;
osgi.identity=camel-blueprint; type=karaf.feature; version="[2.18.0.SNAPSHOT,2.18.0.SNAPSHOT]";
filter:="(&(osgi.identity=camel-blueprint)(type=karaf.feature)(version>=2.18.0.SNAPSHOT)(version<=2.18.0.SNAPSHOT))"
[caused by: Unable to resolve camel-blueprint/2.18.0.SNAPSHOT: missing requirement [camel-blueprint/2.18.0.SNAPSHOT]
osgi.identity; osgi.identity=camel-core; type=karaf.feature; version="[2.18.0.SNAPSHOT,2.18.0.SNAPSHOT]"
[caused by: Unable to resolve camel-core/2.18.0.SNAPSHOT: missing requirement [camel-core/2.18.0.SNAPSHOT]
osgi.identity; osgi.identity=org.apache.camel.karaf.camel-karaf-commands; type=osgi.bundle;
version="[2.18.0.SNAPSHOT,2.18.0.SNAPSHOT]"; resolution:=mandatory [caused by: Unable to resolve
org.apache.camel.karaf.camel-karaf-commands/2.18.0.SNAPSHOT: missing requirement [org.apache.camel.karaf.camel-karaf-commands/2.18.0.SNAPSHOT]
osgi.wiring.package; filter:="(&(osgi.wiring.package=jline.console.completer)(version>=2.1.0)(!(version>=3.0.0)))"]]]
> Error executing command: Unable to resolve root: missing requirement [root] osgi.identity;
osgi.identity=camel-blueprint; type=karaf.feature; version="[2.18.0.SNAPSHOT,2.18.0.SNAPSHOT]";
filter:="(&(osgi.identity=camel-blueprint)(type=karaf.feature)(version>=2.18.0.SNAPSHOT)(version<=2.18.0.SNAPSHOT))"
[caused by: Unable to resolve camel-blueprint/2.18.0.SNAPSHOT: missing requirement [camel-blueprint/2.18.0.SNAPSHOT]
osgi.identity; osgi.identity=camel-core; type=karaf.feature; version="[2.18.0.SNAPSHOT,2.18.0.SNAPSHOT]"
[caused by: Unable to resolve camel-core/2.18.0.SNAPSHOT: missing requirement [camel-core/2.18.0.SNAPSHOT]
osgi.identity; osgi.identity=org.apache.camel.karaf.camel-karaf-commands; type=osgi.bundle;
version="[2.18.0.SNAPSHOT,2.18.0.SNAPSHOT]"; resolution:=mandatory [caused by: Unable to resolve
org.apache.camel.karaf.camel-karaf-commands/2.18.0.SNAPSHOT: missing requirement [org.apache.camel.karaf.camel-karaf-commands/2.18.0.SNAPSHOT]
osgi.wiring.package; filter:="(&(osgi.wiring.package=jline.console.completer)(version>=2.1.0)(!(version>=3.0.0)))"]]]
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message