camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jay mann (JIRA)" <>
Subject [jira] [Commented] (CAMEL-10087) camel-kafka does not work in OSGI container
Date Fri, 24 Jun 2016 22:12:16 GMT


Jay mann commented on CAMEL-10087:

Sorry Jira was down for a long time...  I was able to debug, The problem is the consumer.
 You only implemented the fix for the producer.  The consumer tries to create the following
key classes:


I tried to implement you patch into the consumer, but it fails because it expects "partition.assignment.strategy"
to be an array of strings.  

I don't know how you can work around that without modifying the kafka code.

For reference here is my route:

            <from uri="kafka:localhost:9092?topic=component-in&groupId=jman&autoOffsetReset=earliest&consumersCount=1"
            <log message="Received from Kafka ${body}" />
            <setHeader headerName="kafka.PARTITION_KEY">
            <setHeader headerName="kafka.CONTENT_TYPE">
            <to uri="kafka:localhost:9092?topic=component-out&bridgeEndpoint=true"

> camel-kafka does not work in OSGI container
> -------------------------------------------
>                 Key: CAMEL-10087
>                 URL:
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-kafka
>    Affects Versions: 2.17.1
>            Reporter: Jay mann
> Currently this component is broken in OSGI environment due to this:
> We can leave it broken until they get their bugs worked out.  Or i can submit a PR with
an intermediate fix that should work, as described in the jira noted above.

This message was sent by Atlassian JIRA

View raw message