camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raúl Kripalani (JIRA) <j...@apache.org>
Subject [jira] [Reopened] (CAMEL-10008) camel-spring Karaf feature is incompatible with camel-jms
Date Fri, 03 Jun 2016 08:34:59 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-10008?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Raúl Kripalani reopened CAMEL-10008:
------------------------------------
      Assignee: Raúl Kripalani  (was: Claus Ibsen)

> camel-spring Karaf feature is incompatible with camel-jms
> ---------------------------------------------------------
>
>                 Key: CAMEL-10008
>                 URL: https://issues.apache.org/jira/browse/CAMEL-10008
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-jms, camel-spring, karaf
>    Affects Versions: 2.17.1
>            Reporter: Raúl Kripalani
>            Assignee: Raúl Kripalani
>             Fix For: 2.18.0
>
>
> *camel-jms requires spring [4.1,5):*
> {code}
> karaf@root()> feature:info camel-jms
> Feature camel-jms 2.17.1
> Feature has no configuration
> Feature has no configuration files
> Feature depends on:
>   camel-core 2.17.1
>   spring [4.1,5)
>   spring-jms [4.1,5)
> Feature contains followed bundles:
>   mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
>   mvn:commons-pool/commons-pool/1.6
>   mvn:org.apache.geronimo.specs/geronimo-jms_1.1_spec/1.1.1
>   mvn:org.apache.camel/camel-jms/2.17.1
> Feature has no conditionals.
> {code}
> *camel-spring requires spring [3.2,4):* (because spring-dm no longer works with 4.x and
above)
> {code}
> karaf@root()> feature:info camel-spring
> Feature camel-spring 2.17.1
> Feature has no configuration
> Feature has no configuration files
> Feature depends on:
>   spring [3.2,4)
>   spring-dm [1.2,2)
>   spring-tx [3.2,4)
>   camel-core 2.17.1
> Feature contains followed bundles:
>   mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
>   mvn:org.apache.camel/camel-spring/2.17.1
> Feature has no conditionals.
> {code}
> Installing both Camel features leads to several versions of Spring getting installed
in the container.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message