camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Quinn Stevenson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-9754) Convert from maven-bundle-plugin to bnd-maven-plugin
Date Mon, 04 Apr 2016 19:56:25 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-9754?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15224939#comment-15224939
] 

Quinn Stevenson commented on CAMEL-9754:
----------------------------------------

I've worked through the basics for this, and it looks very promising.

I'm waiting for version 3.2.0 of the bnd-maven-plugin because I need the -snapshot=SNAPSHOT
functionality to replicated what is currently done by the maven-bundle-plugin.

> Convert from maven-bundle-plugin to bnd-maven-plugin
> ----------------------------------------------------
>
>                 Key: CAMEL-9754
>                 URL: https://issues.apache.org/jira/browse/CAMEL-9754
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-core
>            Reporter: Quinn Stevenson
>
> Currently, the v2.3.7 of the maven-bundle-plugin is used to generate the OSGi Manifests
for the Camel libraries.  The project cannot upgrade to a later version of the maven-bundle-plugin
because the newer versions break the build.
> The bnd-maven-plugin is maintained by the same group that maintains the BND libraries
(which both plugins use internally) expedites updates to the plugin when the underlying libraries
change.  Also, the bnd-maven-plugin uses the same BND configuration file format as BND, which
eliminates the complex mapping from XML to BND configuration that the maven-bundle-plugin
has to deal with.
> The goals are:
>  - change from the maven-bundle-plugin to the bnd-maven-plugin
>  - upgrade the OSGi version
>  - upgrade the default OSGi dependencies in the parent POM



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message