camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CAMEL-9721) Camel spring-batch can't be used in OSGI (karaf 4.0.4)
Date Thu, 17 Mar 2016 12:46:33 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-9721?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Claus Ibsen updated CAMEL-9721:
-------------------------------
    Issue Type: Task  (was: Bug)

> Camel spring-batch can't be used in OSGI (karaf 4.0.4)
> ------------------------------------------------------
>
>                 Key: CAMEL-9721
>                 URL: https://issues.apache.org/jira/browse/CAMEL-9721
>             Project: Camel
>          Issue Type: Task
>          Components: karaf
>    Affects Versions: 2.16.2
>         Environment: Karaf 4.0.4
> Camel 2.16.2.RELEASE
> Camel 2.17.0.SNAPSHOT
> JDK 1.7
>            Reporter: Jose Luis Pedrosa
>             Fix For: 2.17.0
>
>
> Hi all
> the camel-spring-batch component does only depend on spring-batch (by pom.xml) but in
the karaf features.xml it is said that it depends on camel-spring (which is not correct but
in test).
> {code:xml}
>  <feature name='camel-spring-batch' version='${project.version}' resolver='(obr)'
start-level='50'>
>     <bundle dependency='true'>mvn:org.apache.geronimo.specs/geronimo-jms_1.1_spec/${geronimo-jms-spec-version}</bundle>
>     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-batch-core/${spring-batch-bundle-version}</bundle>
>     <bundle dependency='true'>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-batch-infrastructure/${spring-batch-bundle-version}</bundle>
>     <feature version='${project.version}'>camel-spring</feature>
>     <bundle>mvn:org.apache.camel/camel-spring-batch/${project.version}</bundle>
>   </feature>
> {code}
> So this has a very downside, that drags the deprecated sprin-dm and impossible to run
anythign on spring higher than 3.2. And the spring-batch version used by camel (2.16.2 needs
spring-batch 3.0.4, that depends on spring 4, which is blocked by adding spring-camel), result,
jar hell, and unable to read the XML Namespace errors. 
> Good this is: removing the dependency of camel-spring and adding spring directly, solves
the issue and can run spring-batch in any upper version correctly.
> thanks!



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message