camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-9467) Camel-Kafka: Upgrade to kafka 0.9 and use the Java client instead of Scala
Date Mon, 07 Mar 2016 09:45:40 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-9467?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15182809#comment-15182809
] 

Claus Ibsen commented on CAMEL-9467:
------------------------------------

If you refer to org.apache.camel.component.test.KafkaConsumerTest, then you need to keep the
JVM running, so add some thread sleep after the start of camel context.

> Camel-Kafka: Upgrade to kafka 0.9 and use the Java client instead of Scala
> --------------------------------------------------------------------------
>
>                 Key: CAMEL-9467
>                 URL: https://issues.apache.org/jira/browse/CAMEL-9467
>             Project: Camel
>          Issue Type: Task
>          Components: camel-kafka
>            Reporter: Andrea Cosentino
>            Assignee: Andrea Cosentino
>             Fix For: 2.17.0
>
>         Attachments: camel-kafka-Anbu.zip, camel-kafka-claus.zip, camel-kafka.zip, camel-kafka.zip
>
>
> From release 0.9.0.0 the Kafka Consumer/Producer configuration properties seems to be
changed a little.
> Also we have to use the new Java implementation of Kafka Producer/Consumer, actually
we are using the Scala version



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message