camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John D. Ament (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-9458) Cannot install camel-ignite in karaf
Date Sun, 21 Feb 2016 20:32:18 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-9458?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15156214#comment-15156214
] 

John D. Ament commented on CAMEL-9458:
--------------------------------------

Hi Raúl,

Ah-ha you're correct.  This is the fully required set of steps now


{code}
karaf@root()> feature:install camel
// ignore this, it shows the error
karaf@root()> feature:install camel-ignite
Error executing command: Unable to resolve root: missing requirement [root] osgi.identity;
osgi.identity=ignite-core; type=karaf.feature; version="[1.5.0.final,1.6.0)"
// end ignore
karaf@root()> feature:repo-add ignite 1.5.0.final
Adding feature url mvn:org.apache.ignite/ignite-osgi-karaf/1.5.0.final/xml/features
karaf@root()> feature:install camel-ignite
{code}

And it installs fine.

> Cannot install camel-ignite in karaf
> ------------------------------------
>
>                 Key: CAMEL-9458
>                 URL: https://issues.apache.org/jira/browse/CAMEL-9458
>             Project: Camel
>          Issue Type: Task
>          Components: camel-ignite, karaf
>    Affects Versions: 2.17.0
>            Reporter: Claus Ibsen
>            Assignee: Raúl Kripalani
>             Fix For: 2.17.0
>
>
> {code}
> karaf@root> features:chooseurl camel 2.17-SNAPSHOT
> Adding feature url mvn:org.apache.camel.karaf/apache-camel/2.17-SNAPSHOT/xml/features
> karaf@root> features:
> features:addurl              features:chooseurl           features:info             
  features:install
> features:list                features:listrepositories    features:listurl          
  features:listversions
> features:refreshurl          features:removerepository    features:removeurl        
  features:uninstall
> karaf@root> features:install camel
> karaf@root> features:install camel-ignite
> Error executing command: Can't install feature camel-ignite/0.0.0:
> No feature named 'ignite-core' with version '[1.5.0-b1,1.6)' available
> karaf@root> features:
> features:addurl              features:chooseurl           features:info             
  features:install
> features:list                features:listrepositories    features:listurl          
  features:listversions
> features:refreshurl          features:removerepository    features:removeurl        
  features:uninstall
> karaf@root> features:info camel-ignite
> Description of camel-ignite 2.17-SNAPSHOT feature
> ----------------------------------------------------------------
> Feature has no configuration
> Feature has no configuration files
> Feature depends on:
>   camel-core 2.17-SNAPSHOT
>   ignite-core [1.5.0-b1,1.6)
> Feature contains followed bundles:
>  mvn:org.apache.camel/camel-ignite/2.17-SNAPSHOT start-level=50
> Feature has no conditionals.
> karaf@root>
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message