camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-9508) camel-sjms to support jms 2.0 in osgi manifest
Date Fri, 15 Jan 2016 04:25:39 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-9508?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15101172#comment-15101172
] 

ASF GitHub Bot commented on CAMEL-9508:
---------------------------------------

GitHub user yogeshrao opened a pull request:

    https://github.com/apache/camel/pull/774

    CAMEL-9508 : support jms 2.0 in osgi manifest

    added jms version range in pom.xml for osgi manifest

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/yogeshrao/camel master

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/camel/pull/774.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #774
    
----
commit f2de32da4db26cf407791b212d4ecfa8902e359b
Author: Yogesh Rao <yogesh.rao@tpt.com>
Date:   2016-01-15T04:21:08Z

    CAMEL-9508 : support jms 2.0 in osgi manifest
    
    added jms version range in pom.xml for osgi manifest

----


> camel-sjms to support jms 2.0 in osgi manifest
> ----------------------------------------------
>
>                 Key: CAMEL-9508
>                 URL: https://issues.apache.org/jira/browse/CAMEL-9508
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-sjms
>    Affects Versions: 2.16.1
>            Reporter: Yogesh Rao
>             Fix For: 2.16.2
>
>
> The camel-sjms component for now supports only jms 1.1 spec, Since the JMS 2 spec maintains
the backward compatibility with jms 1.1 it would be possible for the camel-sjms component
to support jms 2 spec as well. Change in OSGI manfiest would allow camel-sjms to work with
jms 2.0 providers as well.
> Issue was previously discussed in http://camel.465427.n5.nabble.com/camel-sjms-support-for-JMS-2-in-OSGI-td5776164.html



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message