camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrea Cosentino (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-9463) Camel-guice OSGi dependency resolution fails
Date Tue, 05 Jan 2016 16:48:39 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-9463?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15083341#comment-15083341
] 

Andrea Cosentino commented on CAMEL-9463:
-----------------------------------------

Let me know, [~jb@nanthrax.net], if it's ok for you.

> Camel-guice OSGi dependency resolution fails
> --------------------------------------------
>
>                 Key: CAMEL-9463
>                 URL: https://issues.apache.org/jira/browse/CAMEL-9463
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-guice
>    Affects Versions: 2.16.1
>         Environment: Karaf 3.0.5 / 4.0.3
>            Reporter: Frédérik ROULEAU
>            Priority: Minor
>              Labels: karaf, osgi
>
> Camel-guice feature file says it requires com.google.inject/guice/4.0. That bundle do
not export com.google.inject.internal.* classes that are required by camel-guice bundle. This
leads to the error:
> Unsatisfied requirement(s):
> ---------------------------
>    package:(&(package=com.google.inject.internal)(version>=1.2.0)(!(version>=4.0.0)))
> In version 2.15, camel-guice feature was installing guice from service-mix bundle which
was exporting the com.google.inject.internal package.
> It seems that there is no equivalent  ServiceMix  version for guice-4



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message