camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrea Cosentino (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CAMEL-9114) Upgrade Jgroups to version 3.6.7.Final
Date Wed, 13 Jan 2016 07:56:39 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-9114?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrea Cosentino updated CAMEL-9114:
------------------------------------
    Summary: Upgrade Jgroups to version 3.6.7.Final  (was: Upgrade Jgroups to version 3.6.5.Final)

> Upgrade Jgroups to version 3.6.7.Final
> --------------------------------------
>
>                 Key: CAMEL-9114
>                 URL: https://issues.apache.org/jira/browse/CAMEL-9114
>             Project: Camel
>          Issue Type: Task
>          Components: karaf
>            Reporter: Andrea Cosentino
>            Assignee: Andrea Cosentino
>            Priority: Minor
>
> Jgroups 3.6.5.Final is out. We can upgrade.
> I'm trying to test the new bundle and to install the camel-jgroups feature in karaf with
camel-itest-karaf test.
> The behaviour is weird:
> {code}
> ERROR: Bundle org.apache.camel.camel-jgroups [88] Error starting mvn:org.apache.camel/camel-jgroups/2.16-SNAPSHOT
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-jgroups
[88]: Unable to resolve 88.0: missing requirement [88.0] osgi.wiring.package; (&(osgi.wiring.package=org.jgroups)(version>=3.6.0)(!(version>=4.0.0)))
[caused by: Unable to resolve 89.0: missing requirement [89.0] osgi.ee; (&(osgi.ee=Java2SE)(version=1.7.0))])
> org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-jgroups
[88]: Unable to resolve 88.0: missing requirement [88.0] osgi.wiring.package; (&(osgi.wiring.package=org.jgroups)(version>=3.6.0)(!(version>=4.0.0)))
[caused by: Unable to resolve 89.0: missing requirement [89.0] osgi.ee; (&(osgi.ee=Java2SE)(version=1.7.0))]
> 	at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)
> 	at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)
> 	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)
> 	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
> 	at java.lang.Thread.run(Thread.java:745)
> org.osgi.framework.BundleException: Unresolved constraint in bundle org.jgroups [89]:
Unable to resolve 89.0: missing requirement [89.0] osgi.ee; (&(osgi.ee=Java2SE)(version=1.7.0))ERROR:
Bundle org.jgroups [89] Error starting mvn:org.jgroups/jgroups/3.6.5.Final (org.osgi.framework.BundleException:
Unresolved constraint in bundle org.jgroups [89]: Unable to resolve 89.0: missing requirement
[89.0] osgi.ee; (&(osgi.ee=Java2SE)(version=1.7.0)))
> 	at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)
> 	at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)
> 	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)
> 	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
> 	at java.lang.Thread.run(Thread.java:745)
> [org.ops4j.pax.exam.rbc.client.RemoteBundleContextClient] : Remote bundle context found
after 4683 millis
> ERROR: Bundle org.apache.camel.camel-jgroups [88] Error starting/stopping bundle. (org.osgi.framework.BundleException:
Unresolved constraint in bundle org.apache.camel.camel-jgroups [88]: Unable to resolve 88.0:
missing requirement [88.0] osgi.wiring.package; (&(osgi.wiring.package=org.jgroups)(version>=3.6.0)(!(version>=4.0.0)))
[caused by: Unable to resolve 89.0: missing requirement [89.0] osgi.ee; (&(osgi.ee=Java2SE)(version=1.7.0))])
> org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-jgroups
[88]: Unable to resolve 88.0: missing requirement [88.0] osgi.wiring.package; (&(osgi.wiring.package=org.jgroups)(version>=3.6.0)(!(version>=4.0.0)))
[caused by: Unable to resolve 89.0: missing requirement [89.0] osgi.ee; (&(osgi.ee=Java2SE)(version=1.7.0))]
> 	at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)
> 	at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)
> 	at org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1491)
> 	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:334)
> 	at java.lang.Thread.run(Thread.java:745)
> ERROR: Bundle org.jgroups [89] Error starting/stopping bundle. (org.osgi.framework.BundleException:
Unresolved constraint in bundle org.jgroups [89]: Unable to resolve 89.0: missing requirement
[89.0] osgi.ee; (&(osgi.ee=Java2SE)(version=1.7.0)))
> org.osgi.framework.BundleException: Unresolved constraint in bundle org.jgroups [89]:
Unable to resolve 89.0: missing requirement [89.0] osgi.ee; (&(osgi.ee=Java2SE)(version=1.7.0))
> 	at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)
> 	at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)
> 	at org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1491)
> 	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:334)
> 	at java.lang.Thread.run(Thread.java:745)
> {code}
> Looking at the manifest.mf of Jgroups 3.6.4.Final I see this:
> {code}
> Bundle-RequiredExecutionEnvironment: J2SE-1.6
> {code}
> while in 3.6.5.Final we have 
> {code}
> Bundle-RequiredExecutionEnvironment: Java2SE-1.7
> {code}
> and this is normal.
> I would have expected no problem with the camel-itest-karaf test, but it doesn't work.
> Also if you take a look at the config.properties of camel-itest-karaf, at the following
path src/test/resources/org/apache/camel/itest/karaf, you'll see the following row
> {code}
> org.osgi.framework.executionenvironment=J2SE-1.7,JavaSE-1.7,J2SE-1.6,JavaSE-1.6,J2SE-1.5,JavaSE-1.5,J2SE-1.4,JavaSE-1.4,J2SE-1.3,JavaSE-1.3,J2SE-1.2,,JavaSE-1.2,CDC-1.1/Foundation-1.1,CDC-1.0/Foundation-1.0,J2ME,OSGi/Minimum-1.1,OSGi/Minimum-1.0
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message