camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CAMEL-9242) Upgrade slf4j-api to 1.7
Date Tue, 24 Nov 2015 06:29:11 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-9242?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Claus Ibsen resolved CAMEL-9242.
--------------------------------
    Resolution: Fixed

> Upgrade slf4j-api to 1.7
> ------------------------
>
>                 Key: CAMEL-9242
>                 URL: https://issues.apache.org/jira/browse/CAMEL-9242
>             Project: Camel
>          Issue Type: Task
>          Components: camel-core
>            Reporter: Claus Ibsen
>            Assignee: Claus Ibsen
>             Fix For: 2.17.0
>
>
> We have been on 1.6 for a long time, and many others are on 1.7 which can cause problems
such as from karaf / pax-logging
> {code}
> Caused by: java.lang.NoSuchMethodError: org.apache.log4j.Logger.<init>(Ljava/lang/String;)V
> 	at org.apache.log4j.spi.RootLogger.<init>(RootLogger.java:45)
> 	at org.apache.log4j.LogManager.<clinit>(LogManager.java:82)
> 	at org.ops4j.pax.logging.service.internal.PaxLoggingServiceImpl.configureDefaults(PaxLoggingServiceImpl.java:299)
> 	at org.ops4j.pax.logging.service.internal.PaxLoggingServiceImpl.<init>(PaxLoggingServiceImpl.java:70)
> 	at org.ops4j.pax.logging.service.internal.Activator.start(Activator.java:117)
> 	at org.apache.felix.connect.PojoSRBundle.start(PojoSRBundle.java:153)
> 	... 20 more
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message