camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henryk Konsek (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-9145) Upgrade camel-hbase component to hbase 1.1.1 on Hadoop 2.7.1
Date Fri, 18 Sep 2015 07:55:04 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-9145?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14805166#comment-14805166
] 

Henryk Konsek commented on CAMEL-9145:
--------------------------------------

Hi Wojtek,

The usual approach for the multiple API versions support in Camel is to create the another
component that might, but doesn't have to, share some code with the old component. For example
we have Netty (1) and Netty4 (2) components. For former supports Netty 3 and the latter supports
Netty 4.

So if HBase 1.1.1 API is not compatible with our 0.98 component, I propose to create new "hbase1"
component which could try to reuse code from the old "hbase" one.  

Cheers!

(1) http://camel.apache.org/netty
(2) http://camel.apache.org/netty4

> Upgrade camel-hbase component to hbase 1.1.1 on Hadoop 2.7.1
> ------------------------------------------------------------
>
>                 Key: CAMEL-9145
>                 URL: https://issues.apache.org/jira/browse/CAMEL-9145
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-hbase
>    Affects Versions: 2.16.0
>            Reporter: Wojciech Indyk
>
> There is a new HBase version with changed API. HBase 1.1.1 is also a part of Hortonworks
Data Platform 2.3 http://hortonworks.com/hdp/whats-new/ 
> There are changes in HBase 1.1.1 API in compare to 0.98 (currently in Camel). The question
is how to provide two version of camel-hbase (for HBase 0.98 and HBase 1.1.1)?
> I've just started to prepare a version compatible with HBase 1.1.1 and Hadoop 2.7.1



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message