camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Esmann (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CAMEL-9112) Problem upgrading to Camel 2.14.3 in Karaf 3.0.4
Date Thu, 03 Sep 2015 09:27:45 GMT
Michael Esmann created CAMEL-9112:
-------------------------------------

             Summary: Problem upgrading to Camel 2.14.3 in Karaf 3.0.4
                 Key: CAMEL-9112
                 URL: https://issues.apache.org/jira/browse/CAMEL-9112
             Project: Camel
          Issue Type: Bug
          Components: camel-script
    Affects Versions: 2.14.3
         Environment: Windows, Karaf, JDK 1.7
            Reporter: Michael Esmann
            Priority: Minor


I am trying to upgrade to Camel 2.14.3 from 2.14.1. We are using Karaf 3.0.4 as server. 

There is a problem with this, which can be reproduced this way: 

- Make a clean Karaf 3.0.4 installation 

- Start Karaf and install features: 

   feature:repo-add camel 2.14.3 
   feature:install camel 
   feature:install camel-script 

- Stop Karaf and start it again. 

Now there is a warning and stacktrace in the Karaf logfile, as seen below. 
I also tried to additionally install camel-script-jruby and camel-ruby but this didn't help

This warning and stacktrace is not present when using Camel 2.14.1 !! 

--------------------------------------------------------------------- 

2015-09-01 09:49:01,277 | WARN  | FelixStartLevel  | Activator                        | 94
- org.apache.camel.camel-script - 2.14.3 | Cannot create the ScriptEngineFactory: java.lang.IllegalStateException

java.lang.IllegalStateException: Invalid ScriptEngineFactory: org.jruby.embed.jsr223.JRubyEngineFactory

        at org.apache.camel.script.osgi.Activator$BundleScriptEngineResolver.getFactory(Activator.java:231)[94:org.apache.camel.camel-script:2.14.3]

        at org.apache.camel.script.osgi.Activator$BundleScriptEngineResolver.getScriptNames(Activator.java:210)[94:org.apache.camel.camel-script:2.14.3]

        at org.apache.camel.script.osgi.Activator$BundleScriptEngineResolver.access$000(Activator.java:191)[94:org.apache.camel.camel-script:2.14.3]

        at org.apache.camel.script.osgi.Activator.getAvailableScriptNames(Activator.java:118)[94:org.apache.camel.camel-script:2.14.3]

        at org.apache.camel.script.osgi.Activator.updateAvailableScriptLanguages(Activator.java:138)[94:org.apache.camel.camel-script:2.14.3]

        at org.apache.camel.script.osgi.Activator.serviceChanged(Activator.java:184)[94:org.apache.camel.camel-script:2.14.3]

        at org.apache.felix.framework.util.EventDispatcher.invokeServiceListenerCallback(EventDispatcher.java:932)[org.apache.felix.framework-4.2.1.jar:]

        at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:793)[org.apache.felix.framework-4.2.1.jar:]

        at org.apache.felix.framework.util.EventDispatcher.fireServiceEvent(EventDispatcher.java:543)[org.apache.felix.framework-4.2.1.jar:]

        at org.apache.felix.framework.Felix.fireServiceEvent(Felix.java:4419)[org.apache.felix.framework-4.2.1.jar:]

        at org.apache.felix.framework.Felix.registerService(Felix.java:3423)[org.apache.felix.framework-4.2.1.jar:]

        at org.apache.felix.framework.BundleContextImpl.registerService(BundleContextImpl.java:346)[org.apache.felix.framework-4.2.1.jar:]

        at org.apache.felix.framework.BundleContextImpl.registerService(BundleContextImpl.java:320)[org.apache.felix.framework-4.2.1.jar:]

        at org.apache.camel.impl.osgi.Activator$BaseService.doRegister(Activator.java:456)[70:org.apache.camel.camel-core:2.14.3]

        at org.apache.camel.impl.osgi.Activator$BaseService.doRegister(Activator.java:448)[70:org.apache.camel.camel-core:2.14.3]

        at org.apache.camel.impl.osgi.Activator$BundleMetaLanguageResolver.register(Activator.java:238)[70:org.apache.camel.camel-core:2.14.3]

        at org.apache.camel.impl.osgi.Activator.addingBundle(Activator.java:104)[70:org.apache.camel.camel-core:2.14.3]

        at org.apache.camel.impl.osgi.tracker.BundleTracker$Tracked.customizerAdding(BundleTracker.java:431)[70:org.apache.camel.camel-core:2.14.3]

        at org.apache.camel.impl.osgi.tracker.AbstractTracked.trackAdding(AbstractTracked.java:261)[70:org.apache.camel.camel-core:2.14.3]

        at org.apache.camel.impl.osgi.tracker.AbstractTracked.track(AbstractTracked.java:234)[70:org.apache.camel.camel-core:2.14.3]

        at org.apache.camel.impl.osgi.tracker.BundleTracker$Tracked.bundleChanged(BundleTracker.java:407)[70:org.apache.camel.camel-core:2.14.3]

        at org.apache.felix.framework.util.EventDispatcher.invokeBundleListenerCallback(EventDispatcher.java:868)[org.apache.felix.framework-4.2.1.jar:]

        at org.apache.felix.framework.util.EventDispatcher.fireEventImmediately(EventDispatcher.java:789)[org.apache.felix.framework-4.2.1.jar:]

        at org.apache.felix.framework.util.EventDispatcher.fireBundleEvent(EventDispatcher.java:514)[org.apache.felix.framework-4.2.1.jar:]

        at org.apache.felix.framework.Felix.fireBundleEvent(Felix.java:4403)[org.apache.felix.framework-4.2.1.jar:]

        at org.apache.felix.framework.Felix.startBundle(Felix.java:2092)[org.apache.felix.framework-4.2.1.jar:]

        at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1291)[org.apache.felix.framework-4.2.1.jar:]

        at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)[org.apache.felix.framework-4.2.1.jar:]

        at java.lang.Thread.run(Thread.java:744)[:1.7.0_51] 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message