camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Akitoshi Yoshida (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-7800) camel-swagger - Upgrade to swagger that is pure Java based
Date Fri, 18 Sep 2015 09:29:04 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-7800?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14805280#comment-14805280
] 

Akitoshi Yoshida commented on CAMEL-7800:
-----------------------------------------

Hi Claus,
for OSGI support, if we can wait for 1.5.4, that will make life easier (not needing to create
a SMX bundle version of swagger-core-1.5.3.jar).
Do you think we need to get swagger-1.5.4 out before releasing camel-2.16.0 or can use swagger-1.5.3
for the moment without osgi-support and go for swagger-1.5.4 in camel-2.16.1? I really like
to have swagger-1.5.4 out soon but I don't know when this will happen. I'll ask at their ML
again.
In CXF 3.x, we are using optionally swagger-1.5.3 in cxf-rt-rs-service-description but its
OSGi sample currently uses 1.5.4-SNAPSHOT.
regards, aki

> camel-swagger - Upgrade to swagger that is pure Java based
> ----------------------------------------------------------
>
>                 Key: CAMEL-7800
>                 URL: https://issues.apache.org/jira/browse/CAMEL-7800
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-swagger
>            Reporter: Claus Ibsen
>            Assignee: Claus Ibsen
>             Fix For: 2.16.0
>
>
> We should upgrade swagger to their release that is pure java based, that is named 1.5
or something, but is not ready yet



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message