camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Schneider (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CAMEL-9073) Installing camel-cxf on Karaf with Java 7 does not work
Date Tue, 11 Aug 2015 11:06:46 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-9073?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14681617#comment-14681617
] 

Christian Schneider edited comment on CAMEL-9073 at 8/11/15 11:06 AM:
----------------------------------------------------------------------

Will be fixed in karaf 2.4.4.


was (Author: chris@die-schneider.net):
Will be fixed for karaf 2.4.4.

> Installing camel-cxf on Karaf with Java 7 does not work
> -------------------------------------------------------
>
>                 Key: CAMEL-9073
>                 URL: https://issues.apache.org/jira/browse/CAMEL-9073
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-cxf, karaf, osgi
>    Affects Versions: 2.16.0
>            Reporter: Claus Ibsen
>            Assignee: Christian Schneider
>
> See CAMEL-8647
> If you run Karaf on Java 7, then javax annotation 1.1 is exposed by default (see etc/jre.properties).
And when using Java 8, its javax annotation 1.2.
> CXF 3.1.x uses javax annotation 1.2 and then it causes osgi package problems.
> {code}
> karaf@root> features:install camel
> karaf@root> features:install camel-cxf
> Error executing command: Can't install feature camel-cxf/0.0.0:
> Could not start bundle mvn:org.apache.cxf/cxf-rt-rs-extension-providers/3.1.2 in feature(s)
cxf-jaxrs-3.1.2: Uses constraint violation. Unable to resolve bundle revision org.apache.cxf.cxf-rt-frontend-jaxrs
[118.0] because it is exposed to package 'javax.annotation' from bundle revisions javax.annotation-api
[79.0] and org.apache.felix.framework [0] via two dependency chains.
> Chain 1:
>   org.apache.cxf.cxf-rt-frontend-jaxrs [118.0]
>     import: (&(osgi.wiring.package=javax.annotation)(version>=1.2.0)(!(version>=2.0.0)))
>      |
>     export: osgi.wiring.package=javax.annotation
>   javax.annotation-api [79.0]
> Chain 2:
>   org.apache.cxf.cxf-rt-frontend-jaxrs [118.0]
>     import: (&(osgi.wiring.package=org.springframework.context.annotation)(version>=3.1.0)(!(version>=5.0.0)))
>      |
>     export: osgi.wiring.package=org.springframework.context.annotation; uses:=javax.annotation
>   org.apache.servicemix.bundles.spring-context [65.0]
>     import: (osgi.wiring.package=javax.annotation)
>      |
>     export: osgi.wiring.package=javax.annotation
>   org.apache.felix.framework [0]
> karaf@root>
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message