camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Pocock (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-9021) depends on non-free JAR
Date Mon, 27 Jul 2015 10:27:04 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-9021?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14642543#comment-14642543
] 

Daniel Pocock commented on CAMEL-9021:
--------------------------------------

It depends on the JAIN javax.sip JAR

Not all versions have a sources JAR, but if you go and look at one that does have a sources
JAR you will see the license notices:

http://search.maven.org/#search|gav|1|g%3A%22javax.sip%22%20AND%20a%3A%22jain-sip-api%22

This is a common problem with Sun JARs

https://maven.apache.org/guides/mini/guide-coping-with-sun-jars.html

Various projects like Tomcat use alternative versions of the javax.* JARs having a suitable
license.

> depends on non-free JAR
> -----------------------
>
>                 Key: CAMEL-9021
>                 URL: https://issues.apache.org/jira/browse/CAMEL-9021
>             Project: Camel
>          Issue Type: Task
>          Components: camel-sip
>    Affects Versions: 2.15.2
>         Environment: all
>            Reporter: Daniel Pocock
>              Labels: license
>
> The Camel SIP component depends on org.apache.servicemix.specs / org.apache.servicemix.specs.jain-sip-api-1.2
> That JAR depends on javax.sip / jain-sip-api
> The JAIN sip-api classes are not under an Apache compatible free software license.
> The related jain-sip-ri classes (the runtime implementation) are under an Apache compatible
license so this bug doesn't concern them.
> The solution is to change the dependency to org.opentelecoms.sip / sip-api or one of
the other implementations.
> http://search.maven.org/#search|ga|1|sip-api



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message