camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CAMEL-8803) Conflicting classes in camel-jetty9 Maven artifact dependencies
Date Wed, 29 Jul 2015 13:09:05 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-8803?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Claus Ibsen updated CAMEL-8803:
-------------------------------
    Fix Version/s: 2.16.0

> Conflicting classes in camel-jetty9 Maven artifact dependencies
> ---------------------------------------------------------------
>
>                 Key: CAMEL-8803
>                 URL: https://issues.apache.org/jira/browse/CAMEL-8803
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-jetty
>    Affects Versions: 2.15.2
>         Environment: All
>            Reporter: Mikko Tommila
>            Priority: Minor
>              Labels: maven
>             Fix For: 2.16.0
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> The Maven artifact camel-jetty9 depends on org.apache.geronimo.specs:geronimo-servlet_3.0_spec.
> camel-jetty9 also depends on org.eclipse.jetty:jetty-server:jar:9.2.9.v20150224, which
further depends on javax.servlet:javax.servlet-api:jar:3.1.0
> The dependencies of camel-jetty9 include thus two conflicting and different versions
of several classes. Both the Servlet API 3.0 version and Servlet API 3.1 version are included
as (transitive) dependencies.
> Instead of depending on the geronimo artifact, couldn't camel-jetty9 just depend on the
servlet-api artifact (of the correct version)?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message