camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Willem Jiang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-8795) Support for Scala 2.11
Date Mon, 25 May 2015 09:56:17 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-8795?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14558079#comment-14558079
] 

Willem Jiang commented on CAMEL-8795:
-------------------------------------

I don't think camel-karaf can work with Scala 2.11. 
Current camel-karaf just made the dependency of scala language to be provided which means
you need to specify the scala version (2.10.x) yourself, when you use camel-karaf. 

> Support for Scala 2.11
> ----------------------
>
>                 Key: CAMEL-8795
>                 URL: https://issues.apache.org/jira/browse/CAMEL-8795
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-kafka
>            Reporter: Álvaro García Delgado
>            Priority: Minor
>             Fix For: 2.16.0
>
>
> Camel-kafka uses a kafka built with scala 2.10, so it becomes incompatible when used
in a scala 2.11 project in runtime:
> {code}
> A needed class was not found. This could be due to an error in your runpath. Missing
class: scala/collection/GenTraversableOnce$class
> java.lang.NoClassDefFoundError: scala/collection/GenTraversableOnce$class
> {code}
> It seems to be solved excluding the kafka 2.10 dependency and adding the 2.11 version
but I am afraid it could bring up new problems. 
> Thanks, Álvaro



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message