camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrea Cosentino (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-8572) Upgrade aws sdk java version and add support for DynamoDB v2
Date Thu, 02 Apr 2015 21:22:15 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-8572?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14393449#comment-14393449
] 

Andrea Cosentino commented on CAMEL-8572:
-----------------------------------------

PR submitted:
https://github.com/apache/camel/pull/463/

For information purpose I report the most important changes (from PR on github):

There are some new feature to consider:
- The package is different: from com.amazonaws.services.dynamodb to com.amazonaws.services.dynamodbv2
- Key class is gone (among other changes) and it's been replaced by Map<String, AttributeValue>

The most important changes:
- from com.amazonaws.services.dynamodb.model.Key to Map<String, AttributeValue>
- from com.amazonaws.services.dynamodb.model.BatchResponse to List<Map<String, AttributeValue>>
- from com.amazonaws.services.dynamodb.model.KeySchema to List<KeySchemaElement>

- QueryRequest methods withHashKeyValue(AttributeValue) and withRangeKeyCondition(Condition)
now are merged into withKeyConditions(Map<String,Condition>)

- QueryRequest method withCount(Boolean) doesn't exist anymore

So we will even need to make some changes on documentation (I've deleted some constant from
DdbConstants.java class).

Andrea

> Upgrade aws sdk java version and add support for DynamoDB v2
> ------------------------------------------------------------
>
>                 Key: CAMEL-8572
>                 URL: https://issues.apache.org/jira/browse/CAMEL-8572
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-aws
>            Reporter: Andrea Cosentino
>            Priority: Minor
>              Labels: aws, aws-ddb
>             Fix For: 2.16.0
>
>
> Hi,
> We should upgrade the AWS sdk version to something >= 1.9. I've made some test on
the code, and the DynamoDB part of the component is affected from this change.
> We need to support DynamoDB v2, if we want to use a newer version.
> I would like to study this improvement and work on this. Is possible to assign this JIRA
to me? I would like to be able to assign JIRAs to myself. Is it possible? 
> Bye,
> Andrea



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message