camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Freeman Fang (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CAMEL-8530) can't install camel-github feature in karaf
Date Mon, 23 Mar 2015 05:52:12 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-8530?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14375427#comment-14375427
] 

Freeman Fang edited comment on CAMEL-8530 at 3/23/15 5:51 AM:
--------------------------------------------------------------

get exception like
{code}
Caused by: java.lang.Exception: Unable to install bundle mvn:org.eclipse.mylyn.github/org.eclipse.egit.github.core/2.1.5
	at org.apache.karaf.shell.osgi.InstallBundle.doExecute(InstallBundle.java:45)
	... 18 more
Caused by: org.osgi.framework.BundleException: Could not create bundle object.
	at org.apache.felix.framework.Felix.installBundle(Felix.java:2960)
	at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165)
	at org.apache.karaf.shell.osgi.InstallBundle.doExecute(InstallBundle.java:43)
	... 18 more
Caused by: java.lang.IllegalArgumentException: Unable to parse header: com.google.gson;version="[1.6.0,2.2.0]",com.google.gson.annotations;version="[1.6.0,2.2.0]",com.google.gson.reflect;version="[1.6.0,2.2.0]",com.google.gson.stream;version="[1.6.0,2.2.0]
	at org.apache.felix.framework.util.manifestparser.ManifestParser.parseStandardHeader(ManifestParser.java:1926)
	at org.apache.felix.framework.util.manifestparser.ManifestParser.<init>(ManifestParser.java:179)
	at org.apache.felix.framework.BundleRevisionImpl.<init>(BundleRevisionImpl.java:121)
	at org.apache.felix.framework.BundleImpl.createRevision(BundleImpl.java:1243)
	at org.apache.felix.framework.BundleImpl.<init>(BundleImpl.java:112)
	at org.apache.felix.framework.Felix.installBundle(Felix.java:2907)
	... 20 more

{code}


This is caused by that the OSGi header for org.eclipse.mylyn.github/org.eclipse.egit.github.core/2.1.5
isn't correct, the 
{code}
Import-Package: com.google.gson;version="[1.6.0,2.2.0]",com.google.gso
 n.annotations;version="[1.6.0,2.2.0]",com.google.gson.reflect;version
 ="[1.6.0,2.2.0]",com.google.gson.stream;version="[1.6.0,2.2.0]
{code}
miss a "\"" at the end of the line

need use the smx wrapped one(SMX4-1857)


was (Author: ffang):
get exception like
{code}
Caused by: java.lang.Exception: Unable to install bundle mvn:org.eclipse.mylyn.github/org.eclipse.egit.github.core/2.1.5
	at org.apache.karaf.shell.osgi.InstallBundle.doExecute(InstallBundle.java:45)
	... 18 more
Caused by: org.osgi.framework.BundleException: Could not create bundle object.
	at org.apache.felix.framework.Felix.installBundle(Felix.java:2960)
	at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165)
	at org.apache.karaf.shell.osgi.InstallBundle.doExecute(InstallBundle.java:43)
	... 18 more
Caused by: java.lang.IllegalArgumentException: Unable to parse header: com.google.gson;version="[1.6.0,2.2.0]",com.google.gson.annotations;version="[1.6.0,2.2.0]",com.google.gson.reflect;version="[1.6.0,2.2.0]",com.google.gson.stream;version="[1.6.0,2.2.0]
	at org.apache.felix.framework.util.manifestparser.ManifestParser.parseStandardHeader(ManifestParser.java:1926)
	at org.apache.felix.framework.util.manifestparser.ManifestParser.<init>(ManifestParser.java:179)
	at org.apache.felix.framework.BundleRevisionImpl.<init>(BundleRevisionImpl.java:121)
	at org.apache.felix.framework.BundleImpl.createRevision(BundleImpl.java:1243)
	at org.apache.felix.framework.BundleImpl.<init>(BundleImpl.java:112)
	at org.apache.felix.framework.Felix.installBundle(Felix.java:2907)
	... 20 more

{code}


This is caused by that the OSGi header for org.eclipse.mylyn.github/org.eclipse.egit.github.core/2.1.5
isn't correct, the 
{code}
Import-Package: com.google.gson;version="[1.6.0,2.2.0]",com.google.gso
 n.annotations;version="[1.6.0,2.2.0]",com.google.gson.reflect;version
 ="[1.6.0,2.2.0]",com.google.gson.stream;version="[1.6.0,2.2.0]
{code}
miss a "\"" at the end of the line

> can't install camel-github feature in karaf
> -------------------------------------------
>
>                 Key: CAMEL-8530
>                 URL: https://issues.apache.org/jira/browse/CAMEL-8530
>             Project: Camel
>          Issue Type: Bug
>    Affects Versions: 2.15.0
>            Reporter: Freeman Fang
>            Assignee: Freeman Fang
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message