camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Willem Jiang (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CAMEL-8441) Add required 3rd party dependencies to the BOM
Date Fri, 06 Mar 2015 01:35:39 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-8441?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Willem Jiang resolved CAMEL-8441.
---------------------------------
    Resolution: Fixed

Applied the patch into camel master branch and fix some build error and warning message.

> Add required 3rd party dependencies to the BOM 
> -----------------------------------------------
>
>                 Key: CAMEL-8441
>                 URL: https://issues.apache.org/jira/browse/CAMEL-8441
>             Project: Camel
>          Issue Type: Improvement
>            Reporter: Thomas Diesler
>            Assignee: Willem Jiang
>             Fix For: 2.15.0
>
>
> For wildfly-camel we have to redefine a number of camel 3rd party dependencies like this
> {code}
>         <!-- Camel version -->
>         <version.apache.camel>2.14.1</version.apache.camel>
>         
>         <!-- Camel 3rd party versions for artefacts that are not defined in the BOM
-->
>         <version.apache.abdera>1.1.3</version.apache.abdera>
>         <version.apache.activemq>5.10.0</version.apache.activemq>
>         <version.apache.cxf>3.0.2</version.apache.cxf>
>         <version.apache.lucene>4.6.1</version.apache.lucene>
>         <version.apache.mina>2.0.7</version.apache.mina>
>         <version.beanshell>2.0b5</version.beanshell>
>         <version.hapi>2.2</version.hapi>
> {code}
> These should probably come from the camel BOM 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message