camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Willem Jiang (JIRA)" <>
Subject [jira] [Commented] (CAMEL-8432) camel-mqtt: MQTT wildcard ('+') subscription broken
Date Wed, 04 Mar 2015 04:31:05 GMT


Willem Jiang commented on CAMEL-8432:

Hi Mark,
I did the cut yesterday, so it just missed the release train.
I will merge the patch later today.


> camel-mqtt: MQTT wildcard ('+') subscription broken
> ---------------------------------------------------
>                 Key: CAMEL-8432
>                 URL:
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-mqtt
>    Affects Versions: 2.14.1
>            Reporter: Mark Mindenhall
>         Attachments: 0001-CAMEL-8432-2.14.x.patch, 0001-CAMEL-8432-2.15.x.patch
> [MQTT single-level wildcards|]
("\+" character) are broken within topic subscriptions.  This is due to URL encoding/decoding
that is done on the component URI, which results in the "\+" being replaced with a space.
 I also tried with "%2B" instead of the "\+" sign, which gave the same result.  
> A search led me to CAMEL-8056, which mentions needing to override the {{useRawUri}} method
to return {{true}}.  I'm working on a patch and updated unit tests for this.

This message was sent by Atlassian JIRA

View raw message