camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Willem Jiang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-7861) Camel-Spring depends on Spring <4
Date Thu, 25 Sep 2014 02:24:33 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-7861?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14147268#comment-14147268
] 

Willem Jiang commented on CAMEL-7861:
-------------------------------------

spring-dm and some other spring-xxx components do not support spring 4.x so import-range must
be 3.x  only until a solution in karaf exists.

> Camel-Spring depends on Spring <4
> ---------------------------------
>
>                 Key: CAMEL-7861
>                 URL: https://issues.apache.org/jira/browse/CAMEL-7861
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-spring, karaf, osgi
>    Affects Versions: 2.14.0
>         Environment: Karaf 2.4.0
> Spring 4.0.5
>            Reporter: Ray Rishty
>
> When I attempt to start camel-spring in Karaf 2.4.0, I see the below error stating that
I need a version of spring between 3.2 and 4:
> karaf@root> osgi:start camel-spring
> You are about to access system bundle 81.  Do you wish to continue (yes/no): yes
> Error executing command: Error starting bundles:
>         Unable to start bundle 81: Unresolved constraint in bundle org.apache.camel.camel-spring
[81]: Unable to resolve 81.0: missing requirement [81.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.beans)(version>=3.2.0)(!(version>=4.0.0)))
> Checking out the import-package statement via osgi:headers, I see that the Spring dependency
is explicitly less than 4.
>         org.springframework.beans;version="[3.2,4)",
>         org.springframework.beans.factory;version="[3.2,4)",
>         org.springframework.beans.factory.config;version="[3.2,4)",
>         org.springframework.beans.factory.parsing;version="[3.2,4)",
>         org.springframework.beans.factory.support;version="[3.2,4)",
>         org.springframework.beans.factory.xml;version="[3.2,4)",
>         org.springframework.context;version="[3.2,4)",
>         org.springframework.context.event;version="[3.2,4)",
>         org.springframework.context.expression;version="[3.2,4)",
>         org.springframework.context.support;version="[3.2,4)",
>         org.springframework.core;version="[3.2,4)",
>         org.springframework.core.io;version="[3.2,4)",
>         org.springframework.expression;version="[3.2,4)",
>         org.springframework.expression.common;version="[3.2,4)",
>         org.springframework.expression.spel.standard;version="[3.2,4)",
>         org.springframework.expression.spel.support;version="[3.2,4)",
>         org.springframework.jmx.export.annotation;version="[3.2,4)",
>         org.springframework.jmx.export.assembler;version="[3.2,4)",
>         org.springframework.jmx.export.metadata;version="[3.2,4)",
>         org.springframework.osgi.context;resolution:=optional;version="[1.2,2)",
>         org.springframework.remoting.support;version="[3.2,4)",
>         org.springframework.scheduling;version="[3.2,4)",
>         org.springframework.scheduling.concurrent;version="[3.2,4)",
>         org.springframework.scheduling.support;version="[3.2,4)",
>         org.springframework.transaction;version="[3.2,4)",
>         org.springframework.transaction.support;version="[3.2,4)",
>         org.springframework.util;version="[3.2,4)",



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message