camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CAMEL-7835) camel-test-spring doesn't support Spring 4.1.0.RELEASE
Date Thu, 18 Sep 2014 15:08:34 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-7835?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Claus Ibsen updated CAMEL-7835:
-------------------------------
    Component/s:     (was: camel-spring)
                 camel-test

> camel-test-spring doesn't support Spring 4.1.0.RELEASE
> ------------------------------------------------------
>
>                 Key: CAMEL-7835
>                 URL: https://issues.apache.org/jira/browse/CAMEL-7835
>             Project: Camel
>          Issue Type: Task
>          Components: camel-test
>    Affects Versions: 2.14.0
>            Reporter: Henrik
>              Labels: deprecation, junit, spring, test
>             Fix For: 2.15.0
>
>
> CamelSpringJUnit4ClassRunner calls the TestContextManager(Class, String) constructor,
and TestContextManager.getDefaultTestExecutionListenerClasses().  
> Both of these are deprecated in spring-test-4.0.x, and are gone in 4.1.x. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message