camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Willem Jiang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-7741) itest for sanitiycheck Camel running on Karaf 2.x and 3.x
Date Tue, 26 Aug 2014 09:25:57 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-7741?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14110535#comment-14110535
] 

Willem Jiang commented on CAMEL-7741:
-------------------------------------

I just added a profile of karaf3 which could tell pax-exam to switch the version of karaf,
but pax-exam complains the version of felix platform cannot be found when I switch to use
karaf3.
I will create a camel-itest-karaf23 module and commit the patch from running test with  karaf3
profile shortly.


> itest for sanitiycheck Camel running on Karaf 2.x and 3.x
> ---------------------------------------------------------
>
>                 Key: CAMEL-7741
>                 URL: https://issues.apache.org/jira/browse/CAMEL-7741
>             Project: Camel
>          Issue Type: Test
>          Components: osgi, tests
>            Reporter: Claus Ibsen
>            Assignee: Willem Jiang
>             Fix For: 2.14.0
>
>
> We should have a sanity check in itests that check that Camel can deploy and run on karaf
2.x / 3.0.x.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message