camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aki Yoshida (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (CAMEL-7389) camel-quartz component does not define osgi import version for quartz
Date Wed, 23 Apr 2014 12:38:14 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-7389?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Aki Yoshida reassigned CAMEL-7389:
----------------------------------

    Assignee: Aki Yoshida

> camel-quartz component does not define osgi import version for quartz
> ---------------------------------------------------------------------
>
>                 Key: CAMEL-7389
>                 URL: https://issues.apache.org/jira/browse/CAMEL-7389
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-quartz
>    Affects Versions: 2.12.3, 2.13.0
>            Reporter: Stephan Siano
>            Assignee: Aki Yoshida
>            Priority: Minor
>         Attachments: 0001-CAMEL-7389-camel-quartz-component-does-not-define-os.patch
>
>
> As the camel-quartz component is (unlike the camel-quartz2 component) built with a plain
jar (not a bundle) and no version range is defined for the quartz package imports, the import
to the quartz scheduler is generated without version information.
> This will cause issues if the quartz 2.x component is also available on an OSGi system.
> The provided (trivial) patch will limit the import version range for quartz packages.




--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message